All major issues have been identified and resolved over the past days. We have also identified and corrected data affected by the issues. All services should work as expected
The incident will stay in monitoring for a couple of days. If you still experience issues or have questions about you data, please contact support with details
Posted Mar 26, 2026 - 09:01 CET
Update
Several fixed was added to production yesterday, along with update in keys on route for previous pendings. We recommend not publishing pendings today (Tuesday 24.03), if possible wait until tomorrow or later this week.
More fixed are expected today, we will share an update when solutions are available
Posted Mar 24, 2026 - 10:41 CET
Identified
Following last week’s release, introducing support for multiple companies within the same geography, we have identified several functionalities that are not working as intended.
Resolving these issues is our highest priority, and our team is actively working to address them. We recognize that this may cause disruptions and additional work for our customers, and we sincerely apologize for the inconvenience.
We continuously deploy fixes to production as they become available.
At present, three main problem areas have been identified: * Access to and visibility of keys in pendings * Exclusions and coverage where exclusions are applied * Workflows related to pendings (forfall)
We recommend not publishing pendings today (24.03), if possible wait until tomorrow or later this week.
If you have specific questions regarding any of these areas, or are experiencing other issues, please contact our support team. We will follow up with you directly.