Issue generating routes in Buddy

Incident Report for DI

Postmortem

Incident Report: Issue Generating Routes in Buddy

Date: 27 February 2026

Timeframe: 22:00 – 00:18 CET

Incident Summary

On 27 February at 22:00 CET, we were alerted that distribution data for the upcoming night was not available in Buddy. An on-call response team, together with the development team, was immediately assembled to identify the root cause and restore the necessary data in Buddy. At 00:18 CET the data was available in Buddy.

Impact

During the period from 22:00 to 00:18 CET, distribution routes were not available in Buddy. As a result, some couriers were unable to start their shifts at the planned time, causing operational delays.

Once the incident was resolved, route and order data became available for distribution. However, a limited number of records related to newspaper deliveries and courier-delivered single-copy sales were not displayed correctly in Buddy. This resulted in reduced delivery quality for these specific products until the data was corrected.

Cause of Incident

Route and order data were not successfully transferred between the distribution system and the courier application Buddy, which prevented couriers from accessing the necessary information in the app.

The disruption in data transfer has been linked to a database upgrade performed earlier in February, which affected the integration responsible for synchronizing the data.

Resolution

The interruption in data transfer was quickly identified, and work began immediately to restore the data flow.

In addition to re-establishing the normal data transfer process, missing data was also manually transferred to Buddy to ensure operational continuity. Several verification checks were performed to confirm the correct number of parcels (particularly pickup parcels) based on lessons learned from previous incidents.

Additional corrections were made to ensure that all affected records and customer updates were properly updated in Buddy.

Follow-up and Improvements

The following measures have been implemented:

  • Necessary system adjustments to ensure improved data flow between databases
  • Improved alerting procedures, both automated and manual, to enable faster response to similar incidents
  • Enhanced clean-up procedures for this type of incident, including additional verification checkpoints for newspaper deliveries and courier-delivered single-copy sales

Closing Statement

We regret the disruption this incident caused and remain committed to providing a stable and reliable platform for your operations.

Thank you for your patience and continued trust.

Posted Mar 13, 2026 - 15:33 CET

Resolved

Dear customer,
On 27.02.2026 at 22:35, we identified an issue affecting Buddy.
The issue has now been fully resolved. All deliveries and pickup shipments for the distribution cycle are available in Buddy, and the system is operating normally.
We have completed monitoring and can confirm stable performance.
If routes were downloaded during the incident period, please refresh the app to ensure the latest data is displayed.
We sincerely apologize for the disruption this may have caused and appreciate your patience.
Best regards
Distribution Innovation
Posted Feb 28, 2026 - 11:39 CET

Update

Dear customer,

On 27.02.2026 at 22:35, we identified an issue affecting Buddy.

As of 28.02.2026 at 00:30, we can confirm that all deliveries and pickup shipments for tonight’s distribution are now fully available in Buddy.

If routes were downloaded earlier, please refresh the app to ensure the latest data is displayed.

Buddy is now operating normally. We will continue to monitor the system to ensure stable performance.

We apologize for the disruption this may have caused and appreciate your patience.

Best regards
Distribution Innovation
Posted Feb 28, 2026 - 00:54 CET

Monitoring

Dear customer,

On 27.02.2026 at 22:35 CET, we identified an issue affecting Buddy.

As of 28.02.2026 at 00:00 CET, Saturday’s routes are now available in Buddy.

Data synchronization is still in progress. Routes downloaded at this time may not yet include all parcels, particularly late incoming shipments.

We are closely monitoring the synchronization process and will provide a final update once it has been fully completed.

We apologize for the inconvenience this may cause and appreciate your patience.

Best regards
Distribution Innovation
Posted Feb 28, 2026 - 00:09 CET

Update

We are continuing to investigate this issue.
Posted Feb 27, 2026 - 23:29 CET

Update

We are continuing to investigate this issue.
Posted Feb 27, 2026 - 23:25 CET

Investigating

Dear customer,

On 27.02.2026 at 22:35 we discovered an issue with Buddy.


We are currently investigating and working to resolve the matter as quickly as possible. We will keep you informed with updates as the situation develops


We apologize for the disturbance this may cause to your operations.



Best regards

Distribution Innovation
Posted Feb 27, 2026 - 23:18 CET
This incident affected: DI Buddy.